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Workshop Overview

This is an introductory R workshop:

e  That will focus on using RMarkdown to document your analysis
e Ranalyses

Learning environment:

e Let'slearn and have fun!
e Ifyou have questions, please ask them



Learning Outcomes
By the end of this workshop you will be able to:

e Beable to create your own RMarkdown and Word document

Setting up our R Studio

Let’s first set up our working directory. You have a number of options here:

1. Go to Session -> Set Working Directory -> then navigate to the location on your
laptop you would like to use as your working directory for this session

2. Go to Files on the right hand side of your screen -> navigate to the folder you would
like to work from -> then click on the More icon and select Set As Working Directory

3. Type the setwd command as shown below - remember that your slashes are the
opposite direction or you need to type 2: /Workshops/R/W20 is the same as
\Workshops\R\W20

setwd("~/Workshops/AgriFoodData/S23/R_Markdown™)

Let’s also install - if required the following packages:
e rmarkdown - to create our finished documents
To install a new package:

1. Using code: install.package(“rmarkdown”)
2. Using the menus - Tools -> Install Packages -> Enter the name of the package in the
dialogue box -> ensure that the install dependencies is checked

Once you have the packages installed, we need to load them for our session. Two different
ways to do this as well:

1. In R Studio - right hand bottom box - go to the Packages tab - scroll down to the
package you want to load - put a check in the box next to it.

2. Inthe script window - using code - library/()
Exercise 1

1. Install the rmarkdown package

2. Load the packages.
library(rmarkdown)

## Warning: package 'rmarkdown' was built under R version 4.2.3



Getting started with RMarkdown

Available resources:

e  Cheatsheets: (Help -> Cheatsheets)
- R Markdown Cheatsheet
- R Markdown Reference Guide
¢ Online documentation - see R Markdown Quick Tour from RStudio

e R Markdown: The Definitive Guide written by Yihui Xie, ].J]. ALlaire, and Garrett
Grolemund - the creators of R Markdown - [ have a copy if you'd like to see it

e R community
Create First R Markdown Document
Open a new RMD file. File -> New File -> R Markdown...

This will open a new window in the Editor space. You will be asked a few bits of
information to start your file.

New R Markdown

Document L it
I;I Presentation Author: ’A Michelle Edwards, Ph.D., MLIS
R Shiny Default Output Format:

From Template ® HTML

1 Recommended format for authoring (you can switch to PDF or
Word output anytime).

O PDF

PDF output requires TeX (MiKTeX on Windows, MacleX 2013+
on OS X, TeX Live 2013+ on Linux).

O Word

Previewing Word documents requires an installation of MS
Word (or Libre/Open Office on Linux).

OK Cancel

Let’s start by giving our document a Title - your choice! Fill in the Author box. Let’s work
with a Word document to start. Take note of the choices you have at your diposal. I prefer
to start with a Word document to take advantage of the Table of Contents option - then I
will save my Word as a PDF. Please try the different options on your own.



Once you click OK - you will be presented with a new window and the information you
filled in will be visible. The only thing that is missing to start is saving your new RMD (R
markdown) file. So let’s do that first. Remember the file will be saved in your Working
Directory that you set at the beginning of this session.

Format or Layout of the RMD file.

Notice that there are bits of code in the RMD file you just saved. These are examples to
showcase what you can do with this type of file. You'll notice that there are greyed out
areas that contain R syntax and everything else is where you will add your own content.
The information at the top of the file is the same information you filled in the opening
dialogue box. You can make changes to this at any time. Notice that the date is
automatically filled in.

The output type that we selected is Word. Let’s chat about some of the options you have
here before we start writing code and creating our Word document. [ mentioned earlier
that I prefer the Word option because I can take advantage of the TOC option. If you look
carefully at this document, you will see that [ used R Markdown to create it :) I created
headings as | was writing this document to provide sections to organize the file. These
headings are what RMD uses to create the Table of Contents in the Word document.

First step is to say we want to have a TOC (Table of Contents). To do this, scroll to the top
section of your RMD file and hit enter after the output: This will cause the word_document

to move to the nextline. Add a “:” after word_document. Then hit your TAB key 2 times so
your information looks like this

© ] untitled1* @] ANOVA_GLMM.Rmd* @ untitled2* @] ANOVA_GLMM_20191018.Rmd — =
v 4 @ Knit ~ < 1 insert ~ “$Run ~ ‘G ~
1y —— ~
2 title: "Test"

3 author: "A Michelle Edwards, Ph.D., MLIS"
4 date: "February 18, 2020"

5 output:

6 word_documentﬂ

S

R

On the next line we tell R that we want a toc - by saying TRUE and on the following line we
tell it how many levels, by using the toc_depth: option.

@ ] untitled1* @] ANOVA_GLMM.Rmd* @] Untitled2* @] ANOVA_GLMM_20191018.Rmd —
v L <& Knit ~ - 1 insert ~ *Run ~ | & ~

1y ——- "
2 title: 'Partitioning variation: ANOVA to GLMM - What''s it all about?’

3 author: "A Michelle Edwards, Ph.D., MLIS"

4 date: October 17, 2019

5 output:

6 word_document:

7 toc: true

8 toc_depth: 4

9 -
10

Now we’ve set up the environment for our Word document



Creating our first Word document

Before we talk about how we add information into our RMD file, let’s run the example to
see how we create the Word document and what it looks like. Now, I've been using R
Markdown for a while - so I'm hoping that using only the rmarkdown package will work -
Fingers crossed please!

To create the Word document, R uses a process called KNIT - for more information on this
process, please review the video on R Studio - the link was provided in the section above. If
you look just above your editor window you should see an icon that looks like a ball of wool
with needles in it? Let’s take a quick little tour into the option. If you click the little arrow
beside it, you should see a few options - Knit to HTML, Knit to PDf, Knit to Word, and more.
Because we filled in the dialogue box and the top of our file information is complete, R
already knows we want to create a Word document. So by clicking on the icon, it will
automatically create a Word document.

Exercise 2
1. Click on the Knit Icon to try it out!

If you are asked to save the file - please give it a name to save. You should only have to do
this the first time you run the file.

Let’s take a few minutes to debug if needed....

Did you notice the R Markdown below the editor window? It showed you what was
happening as it created the document.

Editing the R Markdown Document

So now that you were able to run the example, take a closer look at the RMD file and the
matching Word document. Notice that the RMD file only has the R script - but when you
created the Word document - you now see the R script along with the output it creates. This
is the beauty of using R Markdown.

R Chunks

The greyed out areas in the RMD file are referred to as R chunks. In order for these areas to
work you need three quotes and {r} code to be at the top and the matching three quotes at
the bottom. This lets RMD know that this is an R script that needs to be run. You can copy
or type in any R script in these areas. If you are unsure whether it works or not, you can
run the R chunk without running or knitting the RMD document together. To do this, you
click on the green arrow at the corner of the R chunk

T {r} »



Naming the R Chunks

[t might be handy to name your R Chunks or pieces of R script. This takes time - but
remember the goal of this exercise is to document your analysis. So, let’s add a name to an
upcoming R chunk, where we will set our Working Directory. To name the chunk you will
type the name after the {r workd_dir} as an example

setwd("~/Workshops/AgriFoodData/S23/R_Markdown™)

Note that you will NOT see it in your Word document but it will be in your RMD and as it is
running you would have seen in the R Markdown log.

Markdown options for Word, HTML, PDF

R Markdown uses different codes and combinations of characters to create options in your
Word document. Best way to see some of these is to review the Cheatsheet. Trust me, I
have it next to me every time I create a new RMD file.

Let’s open the Cheatsheet and review some of the more common ones that may be used:

e Headings

e  Ordered and unordered lists (bullets)
e Bold

e Italics

e Addingalink
e Adding an image

This document uses all of these features.
So what are you documenting?

The beauty of R Markdown is that everything is in one file. You have your R script and the
matching output. All you need to do now is to add your thoughts, notes, description,
interpretation to the document. You might write about what the upcoming R script is going
to do - what the analysis is - what model you are using, etc.. Then after the R script you may
discuss what you are seeing in the output. If you want to see what the output looks like
BEFORE you create the Word document, remember that you can run the R chunk by
clicking on the green arrow.

Let’s use a test file in R and run a summary/() function on it. Add a new R chunk by going to
Insert and selecting R



You can add a name to this R chunk by typing a name after r - type a space first and then
your name. Let’s call this one cars. On the next line - let’s type in the R function
summary/(cars)

summary(cars)

H## speed dist

## Min. : 4.0 Min. : 2.00
## 1st Qu.:12.0 1st Qu.: 26.00
## Median :15.0 Median : 36.00
## Mean :15.4 Mean : 42.98
## 3rd Qu.:19.0 3rd Qu.: 56.00
## Max. :25.0 Max. :120.00

Including Plots

You can also embed plots, for example:
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Note that the echo = FALSE parameter was added to the code chunk to prevent printing of
the R code that generated the plot.

You can see how you can write a blurb about the analysis you are conducting, then RUN the
analysis, and write another blurb after the output as your interpretation. Pretty cool eh???

TO make your document pretty or ugly - use the Cheatsheet to guide you. Once you've
created your document as a Word, you can then continue to make format changes in Word.
Then save it all as a PDF.



This makes your research replicable - the only thin missing is the data. But you can point to
the source of the data.

Other ways to document your analysis????

Adding comments in your SAS syntax or your R script. This again can be challenging, take a
lot of time - but it is worth the time! Adding a comment to your code to explain why you are
running the analysis - what your outcome measure is, where it comes from, any
manipulations you did, is very helpful. Remember we want to make our studies
reproducible - we want to ensure the next individual that uses your data, can reproduce
your results. Without information about your data and your analysis this will be next to
impossible.

Commentsin R

To add a comment in an R script we use the # sign. Let’s repeat some code from before, but
this time we’ll add a comment to it.

# I'm using the S230 directory in my AgriFoodData Workshops as my working
directory
setwd("~/Workshops/AgriFoodData/S23/R_Markdown")

Notice in the R script area it is green type and in the Word document it is bronw and
italicized. There is no limit to how many comments you can add in your script file. So feel
free to document the story of your data analysis in your script file.

Conclusion

Documenting your data analysis can be done using something like RMarkdown , which
allows you to build the story before, during, and after the analysis- all in one document.

You can also begin to document your analysis by adding comments to your code.



